Off Topic A place for you car junkies to boldly post off topic. ALMOST anything goes.

Google chrome internet browser

  #1  
Old 09-04-2012, 08:21 AM
Banned
Thread Starter
Join Date: Dec 2011
Location: Canada
Posts: 2,636
Thumbs up Google chrome internet browser

This is my experience with Google Chrome as my internet browser. I have Windows "XP" on my laptop. I DJ part-time and the company I work for has supplied me with an extra e-mail account for DJ'ing. It was working for a while, but not at all 2 weeks ago with my previous browser Internet Explorer. Last week, i also tried to purchase a song on-line and it did not work anymore. I tried to make the sites "Trusted" and allow cookies, but that did not help. I decide to take my computer to the guru at my DJ place. He updated the latest version of Adobe Flash Player for me (I thought it was the latest, to my dismay). We tried to access my DJ e-mail and it still did not work. He then changed my Internet Explorer Browser to Google Chrome. Now it works! I was also able to buy that song on-line for this week's coming wedding. Now I have access to everything. With "XP", i probably have limited access to an earlier version of Internet Explorer (which may have caused these problems). I also notice Google Chrome is a bit quicker. We were also able to transfer all my favorite links from Internet Explorer to Google Chrome with the click of a button in the settings. I still have access to Internet Explorer as well, but it is secondary. So far so good with Google Chrome as my Internet Browser.
 
Attached Thumbnails Google  chrome  internet  browser-images.jpg   Google  chrome  internet  browser-imagesca18rjrh.jpg   Google  chrome  internet  browser-justsimple.jpg  
  #2  
Old 09-04-2012, 11:13 AM
Senior Member
Join Date: Feb 2012
Location: Tirol, Austria
Posts: 756
Default

Good idea to keep IE as a backup, there are some pages that Chrome just does not like but run fine in IE.
 
  #3  
Old 09-04-2012, 12:40 PM
Banned
Thread Starter
Join Date: Dec 2011
Location: Canada
Posts: 2,636
Default

I just checked that i have Internet Explorer "8" as my back-up.
Back-up plans are always good. I have all my music on a separate hard-drive as well.
 
  #4  
Old 09-04-2012, 02:59 PM
virgin1's Avatar
Super Moderator
Join Date: Mar 2007
Location: Manor, TX (Outside of Austin)
Posts: 8,660
Default


I use both browsers too and prefer Chrome. It seems to suck up much less ROM than Chrome does. Since my laptop is really a netbook, using IE, 9 in my case, usually means I have to reboot shortly after closing down IE. It doesn't seem to go away completely when closed out and still takes away memory.
Chrome has been grest for me in all circumstances.

 
  #5  
Old 09-05-2012, 10:00 AM
virgin1's Avatar
Super Moderator
Join Date: Mar 2007
Location: Manor, TX (Outside of Austin)
Posts: 8,660
Default


Yes, I meant IE 9 seems to take and hold more memory, even with no active add-ons (Google, Bing, etc) and after shut down.
It's the worst version of IE I think I've ever used.
 
  #6  
Old 10-05-2012, 07:08 PM
Banned
Thread Starter
Join Date: Dec 2011
Location: Canada
Posts: 2,636
Default

UPDATE: after having it for a month, it has slowed down and doesn't load as fast any more. Probably due to the stricter settings i used for blocking certain sites and cookies.
It works great for watching live TV streams as i can have access to latest Adobe updates with it.

Problem with opening some emails: left clicking to open emails sometimes yields no response. I have to open other ones first and then go back to the one that didn't open, and it finally will open.
 

Last edited by UseYourNoggin; 10-21-2012 at 08:11 AM. Reason: Email opening
  #7  
Old 04-12-2013, 09:00 AM
Banned
Thread Starter
Join Date: Dec 2011
Location: Canada
Posts: 2,636
Default

I have had a new computer for a couple of months now. It came with Windows 8 and Internet Explorer 10. Internet Explorer 10 is the worst version yet. It all of a sudden stops working, then it does come back. This morning I was 90% done making a post then it F__cked up on me and told me I wasn't signed in (when i could see my name there). I re-signed in to MazdaForum and lost my post.
Recently i have been using Google Chrome and never had an issue. But yesterday a bunch of Windows updates were loaded and i'd though i would try Internet Explorer again-----obviously that was a bad decision. It's a shame i can't even be on web for a short time without Internet Explorer F__cking up.
++++ for Google Chrome!
 
  #8  
Old 04-15-2013, 03:51 PM
virgin1's Avatar
Super Moderator
Join Date: Mar 2007
Location: Manor, TX (Outside of Austin)
Posts: 8,660
Default

do ya' get the feeling you are stuck in the middle of a war (over money) that you didn't ask for?
I know I do.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mazda guy
Off Topic
0
08-30-2010 10:43 AM
6Pack
Mazda6
7
11-14-2005 11:21 PM
JKoolMann
Mazda6
0
08-26-2005 12:01 PM
danimal
Mazda6
2
07-22-2005 11:49 AM


Thread Tools
Search this Thread
Quick Reply: Google chrome internet browser


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.