Tried out swapping radio front panel - now nothing works - Mazda Forum - Mazda Enthusiast Forums

Go Back  Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda6
Reload this Page >

Tried out swapping radio front panel - now nothing works

Mazda6 This powerful new sedan offers a sporty feel and stout engine, all without compromising the ability to seat 5.

Tried out swapping radio front panel - now nothing works

Reply

 
 
 
  #1  
Old 06-13-2018, 03:11 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Location: Croatia
Posts: 1
Default Tried out swapping radio front panel - now nothing works

Hello to all,

I have a bit of an issue after trying to install the AUX mod.
The problem is basically that i didn't know about the side bolt holding the radio in place and basically wanted to "extract it by force" --> which of course broke the electronics on the radio front face.

So, i went out and bought a new plastic front face with all the electronics but without the radio unit.
Assembled everything but now i only get the info i attached with the picture.So i get the usual "Hello" on the display ; and then just the date.

There is no "beep" sound which was usually there when you press any button... and no indication if the A/C works or the temperature...

What i tried doing:
- Disassembling the display unit, checking the contacts
- Cleaning out the contacts between the radio and front plastic
- Pushing on the front plastic (that garbles up the signal to the display unit)

Oh yeah, and the radio doesn't work

So, any help whatsoever or advice... or even pointing me to a post here on the forum would be greatly appreciated!
Because now i'm at a point where I am seriously considering throwing away 200$ on one of those e-bay front mask kits for a double DIN radio...

Thanx
 
Attached Thumbnails Tried out swapping radio front panel - now nothing works-img_20180219_190655.jpg  
Reply With Quote
  #2  
Old 06-14-2018, 08:38 AM
Super Moderator
Join Date: May 2012
Location: Queensland Australia
Posts: 2,990
Default

Can you take a photo of the "front face" you bought?

Are both panels silver? What year are the two panels? Have you checked both Audio fuses?
 
Reply With Quote
  #3  
Old 06-21-2018, 07:47 AM
Junior Member
Join Date: Jun 2018
Location: Wisconsin
Posts: 4
Default

reading this post I thought it was me lol. I did the same exact thing. after looking at it closer the radio fix was very easy. If you take the radio off of the plastic panel there are some plugs on the plastic part. I am assuming your LCD on top for heater controls are not working also? Ijust had to strainghten out the plugs you will see what I mean when you get it apart.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jerfran1111
General Tech
1
09-07-2014 04:33 PM
800degrees
Mazda CX-9
0
05-04-2013 10:33 AM
binky
Nitrous, Super Chargers, & Turbos
2
03-24-2008 07:36 PM
jordansportsfan
Off Topic
5
02-18-2007 10:24 PM
mrsegal21
Mazda Millenia
3
01-26-2007 12:20 AM


Thread Tools
Search this Thread
Quick Reply: Tried out swapping radio front panel - now nothing works


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.