Go Back  Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda MPV
Reload this Page >

Starts fine after sitting idle for awhile but then it won't restart

Mazda MPV This minivan was among the class leaders with its roomy interior and efficient powertrain.

Starts fine after sitting idle for awhile but then it won't restart

  #1  
Old 02-10-2015, 03:06 PM
Junior Member
Thread Starter
Join Date: Feb 2015
Location: Ontario
Posts: 1
Question Starts fine after sitting idle for awhile but then it won't restart

1990 Mazda MPV (manual shift) has been running fine until December. It starts on the first crank after sitting idle overnight. It drives around town with no problems but then I turn off the engine, it does not start again. It cranks over but does not start. Sometimes it needs to sit for a few hours before it starts again. Also, this is an intermittent problem, some days I have no problems at all.

I have had into the mechanic and they can't find the problem either.

I do not know if it is the cold temperatures that affect the starting.
New spark plugs, leads, distributor, timing belt were replaced in 2013.
Any suggestions?

Thank you
 
  #2  
Old 02-10-2015, 09:55 PM
Senior Member
Join Date: Aug 2007
Posts: 1,324
Default

Probably the ignition coil. If original it is 25 years old. Pretty much any distributor bought in 2013 will be Chinese made and not the greatest quality so is suspect. You need to check for spark/fuel pressure/injector pulse when it fails to start. The spark should be blue and not orange. Orange is weak spark. Once we know what is missing it will narrow it down.
 
  #3  
Old 02-13-2015, 06:30 AM
Super Moderator
Join Date: May 2012
Location: Queensland Australia
Posts: 3,463
Default

Cam & crank position sensors can also suffer from heat soak.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
adabre
Mazda Tribute
4
01-03-2017 06:10 PM
Jaxxxon
General Tech
4
10-19-2016 12:49 PM
mattyjt
Mazda CX-5
5
01-14-2015 09:31 AM
2000MysteriousS
Mazda Millenia
15
03-10-2009 07:35 AM


Thread Tools
Search this Thread
Quick Reply: Starts fine after sitting idle for awhile but then it won't restart


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.