Mazda MPV This minivan was among the class leaders with its roomy interior and efficient powertrain.

fluctuating idle with no codes

  #1  
Old 12-09-2007, 10:11 PM
Thread Starter
Join Date: Nov 2007
Posts: 6
Default fluctuating idle with no codes

I have had some issues with my 2001 MPV. I replaced a few things that came up when I had it scanned and there are no longer any codes coming up. I have hesitation when I try to accelerate when I am at a stop. When I am sitting at a light, I have to hold my foot on the gas pedal or it will stall. When it doesn't stall, the idle fluctuates up and down and back up and down.....you get the picture. It does backfire a little also. I have replaced my MAF sensor and my IMRC. Those were the codes that came up. I also fixed a vacuum leak that took care of another code P0300. No codes and still a problem. Can anyone help me out on this?? I am in desperate need. I do not want to go the dealer and get reamed. It is acting like it is flooding out. It smells really rich out the tailpipe. Does that rule out a clogged fuel filter?? There is some kind of a vacuum regulator that is right by my MAF sensor. When I unplug the vacuum sensor(or whatever it is) nothing happens. Does that sound normal?? This vacuum sensor has one hose going to my PCV valve (i believe) and the other hose goes to a little canister that is connected to my air filter housing. Is this "vacuum regulator" going to be related to my problem?? PLEASE HELP ME!!!!! I have already dropped 500.00 into this, but something still isn't right!!!!
 
  #2  
Old 12-17-2007, 09:14 PM
Join Date: Dec 2007
Posts: 1
Default RE: fluctuating idle with no codes

I have pretty much the same problem. 2000 MVP idles extremely rough with rpms jumping from 500 or less to over 2,000. Very hard to start in the mornings and dies virtually at every stop. Have already changed plugs and wires. Ignition coil ohms test comes out okay. Idle air control valve ohms tests okay. Egr seems to function properly however, I do here a bunch of clicking from the egr valve when the engine tries to adjust itself from a low idle to a high idle. Again, no codes are present. Engine seems to smooth out on acceleration and driving. (Update) I have now checked fuel pump and screen and all is well with these components as well.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
simmonsp5
Mazda CX-7
4
08-09-2014 02:44 PM
milehighProtege
Mazda Protege
4
04-13-2012 09:01 AM
tradosaurus
Mazda Protege
1
12-31-2011 03:50 PM
REDKAISER
Mazda 323,Mazda 626 & Mazda 929
2
12-20-2007 02:52 PM
uscavalryscout
Mazda 323,Mazda 626 & Mazda 929
7
05-09-2006 12:14 PM


Thread Tools
Search this Thread
Quick Reply: fluctuating idle with no codes


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.