Go Back   Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda Protege
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-30-2011, 05:40 AM
Junior Member
 
Join Date: Jun 2011
Location: Northern California
Posts: 2
Default Ignition switch replace

I've got an 02 that is having electrical problems. The other day it lost power (electrical) but cam back right away, this happened twice. The third time I lost power the car died completely and had to be towed home. After getting home it started like nothing happned. The battery and charging system checked out fine so I think it's the ignition switch. Has anyone replaced this and how do I do it?
I have fixed 2 other problem with everyones help, hoping for 3 x 3
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 07-01-2011, 11:42 AM
Senior Member
 
Join Date: Sep 2008
Posts: 292
Default

are your cables on your battery on there tight and there is nothing baked onto the posts? cause i had something like what you described happen on a farm truck and it was because the positive cable was loose. Ignition switchs are all plug and play you basicly just take the cover off just behind your steering wheel and it should just be screwed on i havn't done it on a protege but you shouldn't have any problem doing it.
Reply With Quote
  #3  
Old 07-01-2011, 01:26 PM
Junior Member
 
Join Date: Jun 2011
Location: Northern California
Posts: 2
Default

Yes the batery cables are tight, and to prevent corrosion from starting I painted the terminals red and black. I've benn painting these for years and never had a problem. I pick up the ignition switch today, wish me luck!
Reply With Quote
  #4  
Old 08-23-2011, 05:02 PM
Junior Member
 
Join Date: Mar 2007
Posts: 1
Smile Ignition Switch

Hi, I saw your thread and I was wondering if replacing the Ignition Switch ended up being the fix on your car. I have the 2003 Protege 5, same problem with random starting. I am going to bring it to be fixed but I am pretty sure it is the ignition switch. Just seeing how you made out. Thanks a bunch.
__________________
Illegal Girl
Reply With Quote
Old 08-23-2011, 05:02 PM
 
 
 
Reply

Tags
2000, 97, forum, ignition, location, lock, loose, mazda, problem, protege, removal, replace, replacement, replacing, switch


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Med Center Mazda
Pelham, AL 35235


All times are GMT -5. The time now is 11:44 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.