Mazda 3 2007 left side speakers not working. - Mazda Forum - Mazda Enthusiast Forums


New Member Area New to MF? Stop in tell us about you.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-09-2018, 01:29 PM
Junior Member
Thread Starter
 
Join Date: Jul 2018
Location: Devon
Posts: 3
Default Mazda 3 2007 left side speakers not working.

Hi all
I have a mazda 3 2007 and the left side of the cars speakers stopped working a few months ago sometimes when the car gets hot or the engine they will work again. I have today spent a fortune on upgrading the head unit etc but still the same problem. I have been told it could be the in car amp but where is it?? I have checked under both front seats and nothing there. I have been told off a possible Bose amp but I don't think its the Bose system as nothing is labelled with Bose . I'm at my wits end and really could do with some help.
Reply With Quote
  #2  
Old 07-10-2018, 02:53 AM
Super Moderator
 
Join Date: May 2012
Location: Queensland Australia
Posts: 2,823
Default

Have you tested the speaker wiring & the speakers themselves?
Reply With Quote
  #3  
Old 07-10-2018, 03:30 AM
Junior Member
Thread Starter
 
Join Date: Jul 2018
Location: Devon
Posts: 3
Default

I have had someone look at it and they told me it's not the speakers or the wiring possibly the built in amp , thing is when I Google where the amp is it says under passenger seat but there is nothing there? Have read that some mazda 3 have little amps inside the door but I ain't no car expert so don't want to rip panels off. Maybe I take it to mazda garage.
Reply With Quote
  #4  
Old 07-10-2018, 06:40 AM
Super Moderator
 
Join Date: May 2012
Location: Queensland Australia
Posts: 2,823
Default

If there are no "Bose" logo's on the head unit or door cards, then you don't have the bose system & there-for no amplifier.

You need someone with audio experience to test the speakers & wiring.
Reply With Quote
  #5  
Old 07-10-2018, 07:05 AM
Junior Member
Thread Starter
 
Join Date: Jul 2018
Location: Devon
Posts: 3
Default

Awesome thanks for your help much appreciated.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2007 b2300 Brake light and turn signal on passenger side not working. Greenmustard83 General Tech 1 04-28-2015 06:49 AM
2010 Mazda 5-Power Windows and side mirrors not working petersaywhat Mazda5 4 11-15-2014 04:18 PM
Fan not working Rear Defroster not working. CanAva Mazda Protege 0 11-10-2014 04:54 PM
Left side turn signal not working naellool Mazda MPV 0 12-27-2010 07:01 PM
left rear turn signal not working, fast flashing bleepbloop General Tech 3 01-26-2007 10:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 04:57 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.