Go Back  Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda3
Reload this Page >

04 Mazda 3s First Surging and Stalling / Now it wont start. Please Help

Mazda3 Offered in both a sedan and wagon, this sporty model offers a great car for the family, as well a fun track car.

04 Mazda 3s First Surging and Stalling / Now it wont start. Please Help

  #1  
Old 04-16-2019, 12:03 PM
Junior Member
Thread Starter
Join Date: Apr 2019
Location: Stockton, CA
Posts: 6
Angry 04 Mazda 3s First Surging and Stalling / Now it wont start. Please Help

Hello Everyone,

I am in need of assistants. I cannot figure out what is wrong with my car. I own a 2004 Mazda 3s 2.3L 5 Speed, 286k miles on car 30k miles on fully rebuilt engine. I will take you through the progression of symptoms and the repairs I made along the way to provide insite. Please let me know if you had similar problems and what you did to repair it.

-Initially out of no where my car started surging while driving and low speeds and was hard to start. It progressed to surging more frequently and then stalling at idle.(This all happened very inconsistently no pattern to it at all) I had no check engine light at all. I figured the fuel pump was going bad so I ordered one and replaced it. The problem continued and got progressively worse.

- Finally a code came up P0340 cam shaft position sensor. I replaced the sensor. The code went away but the problem persisted.

-I removed and cleaned the Throttle body, replaced the Purge Control Valve, and used the warranty to replace the Cam shaft sensor again (Just in case I got a bad one of the shelf) I did a reset on the computer (disconnected the battery, pressed the break 5 times, let it set, and then did the idle procedures) The problem got worse.

-So at this point the car would start and run great until it got to operating temp then it would die and I wouldn't get it to start again until it set for a few hours (NO it was not overheating).

-Once again I found my self back in the garage working on it. I verified the Timing was correct (I have the Mazda factory timing tool set) It is spot on. While it was at TDC I replaced the Crank Shaft Position sensor. I put it back together.
(Non related to the issue but a repair that needed to be done I replaced the Plugs, Valve cover gasket, and the coil packs)

NOW MY CAR WILL NOT START AT ALL it just cranks.

I think my ECU is bad but I want a second opinion before I spend the money.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Amorrow37
General Tech
0
04-16-2019 10:31 AM
Mazdaboy75
Mazda CX-7
1
06-29-2018 06:09 PM
EWHOLTZCLAW
Mazda Millenia
8
02-06-2010 07:11 PM
nooddles1
Mazda6
1
01-10-2010 06:36 PM
jakejohn
Mazda 323,Mazda 626 & Mazda 929
4
05-14-2006 11:20 PM


Thread Tools
Search this Thread
Quick Reply: 04 Mazda 3s First Surging and Stalling / Now it wont start. Please Help


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.