2006 3.0 V6 compounding problems all at once - Mazda Forum - Mazda Enthusiast Forums


Mazda Tribute This low-priced SUV allows the driver the versatility of an SUV without the big fuel bill of many of the vehicles in the SUV class.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-13-2018, 10:26 AM
Junior Member
Thread Starter
 
Join Date: Jan 2017
Location: Florida
Posts: 3
Default 2006 3.0 V6 compounding problems all at once

2 weeks back wife said car stalled and AC abruptly stopped. Codes read 352,354,355. Ordered motorcraft platinum plugs and delphi COPs and replaced all 6 with upper plenum gaskets. Car still running rough and making a popping sound through intake that can be heard louder if unclipping air filter slightly ajar. Was gonna go get a vacuum tester and troubleshoot this then move on to AC and buying a manifold gauge...well haven't got to those problems yet as now the battery is dying overnight and I'm showing a parasitic drain of around 190ma that goes away if I pull fuse 19 and 21 under the hood and 17 in passenger compartment. These are related to low beam and cluster stuff. I've had the ammeter hooked up for 45 minutes and still same numbers showing. Funny that I wanted to try and fix that other stuff, but I need a working 12.6V to do so and now it's like adding more and more problems. After a jump the battery reads around 14.2V when running, so the alternator seems okay, but drains overnight if left connected. Last night I removed Neg. cable and battery stayed at 12.53V when checked this morning.

102,000 Miles


Edit: After an additional half hour of leaving ammeter connected it went down to an acceptable 20ma so gonna go get a new battery as that seems to be the issue here as battery only read 12.3V after. Then it's on to the original big problems of why AC went out and why the popping noise.

Last edited by KBWood; 07-13-2018 at 11:01 AM.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
transmission error code all at once katocal Mazda3 5 04-03-2015 11:38 PM
Many Problems at once with my 2003 Mazda Tribute CyberDaeng Mazda Tribute 2 05-01-2013 02:55 AM
1990 Protege clicks once instead of starting Xaisho Mazda Protege 7 11-23-2010 06:12 PM
91' b2200 threw 5 check engine codes at once! jgro650 Mazda Pickup Trucks 0 06-22-2010 06:34 PM
once again a newbe staticdroppedb2200 New Member Area 0 02-13-2010 02:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 04:58 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.