Mazda MX-3 and Mazda MX-6 These two sporty models have become popular cars for import tuners due to the availability of parts, the low price, and the smooth lines.

MX-3 'No Start,' no code situation

  #1  
Old 06-01-2019, 07:58 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Location: Phoenix, AZ
Posts: 7
Unhappy MX-3 'No Start,' no code situation

Actually, I do have one code, code 16, which I believe is for the EGR valve, but all that is new, and besides, would not cause a 'no start.' I started losing 20-30% of my acceleration/power a few weeks ago. I noticed some minor sputtering at idle, but didn't think too much about it yet. Yesterday, the idle sputter became more present. I took off for a semi-long expressway round trip, an hour each way. About 12 miles from home, I had a sudden decrease in power, and could no longer maintain highway speed, so, I bailed out. Nursed it for probably another couple miles, tons of sputter now, then it died and would not start back up. Today, I pulled the cat in case it were clogged. Not. I also checked for spark, spark seems strong enough. I'm going to try to test the fuel pressure, but my neighbor's kit seems too barebones to be useful. Distributor, wires, etc, fuel pump, fuel pressure regulator, fuel filter, all vacuum solenoids and vacuum lines; all very recent new parts. I don't think my timing belt broke, or, it would have totally failed immediately. And, I don't really think it skipped a tooth (although I have never experienced this_) because, if it kept running after skipping a tooth, why would it not keep running poorly? I do suppose it could have skipped another tooth if that were the case, then that could have caused it to die with no available re-start, but I don't know. So, I seek any/all input; thank you.
 
  #2  
Old 06-01-2019, 08:25 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Location: Phoenix, AZ
Posts: 7
Default Oh Sorry . . .

It is a '93 GS SE with stock 1.8L V6 with 265k miles on it; full compression (+/- 200 psi each cylinder_) last time I measured it; not too long ago. Many many new or recent parts. Status of timing belt unknown as it was a dealership purchase, and they would not allow me to contact the previous owner, so, all I could go by was if parts looked newer or not.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Baston-Rob
Mazda6
4
12-25-2011 04:48 PM
Bobbygian
Mazda Protege
0
09-30-2010 09:07 AM
lovemy3
Mazda3
1
03-30-2009 04:09 PM
poet1234567
Mazda Millenia
0
07-09-2006 08:46 AM


Thread Tools
Search this Thread
Quick Reply: MX-3 'No Start,' no code situation


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.