Mazda MPV This minivan was among the class leaders with its roomy interior and efficient powertrain.

91 MPV sputtering, then no start

  #1  
Old 10-30-2007, 08:58 PM
Thread Starter
Join Date: Oct 2007
Posts: 1
Default 91 MPV sputtering, then no start

I changed the oil on my van, and added some Marvel Mystery oil to the crankcase and fuel, as well as a bottle of upper cylinder lubricant. I then drove about 100 miles, and towards the end of the trip I would come to a stop, and when trying to accelerate after stopping, the engine would sputter down almost to stall and I'd have to give it quite a bit more gas than normal to get it up to speed. After shifting to second gear it responded normally. This morning I changed the spark plugs and afterwards it won't start. Cranks normally, but no turn-over. I'll be replacing the spark plug wires when they get in on thursday, and will be checking out my distributer rotor and points tomorrow morning. I was also thinking perhaps the fuel treatment could have dislodged a bunch of gunk and clogged my fuel filter. Can anyone tell me where this is located so I can check/replace it? Anything else you might know to check on please let me know. Thank you.

Zairian

1991 MPV 2wd, 4cyl engine.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JWheeler
Mazda MPV
1
11-27-2010 10:29 AM
mankaw
Mazda MPV
4
07-31-2010 12:13 PM
horan_c
Mazda Millenia
0
06-24-2008 10:03 PM
pv107
Mazda MPV
7
06-15-2007 07:06 PM
Chubs
General Tech
3
10-21-2005 01:03 AM


Thread Tools
Search this Thread
Quick Reply: 91 MPV sputtering, then no start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.