2010 iT works, and then doesn't? Frustrating. - Mazda Forum - Mazda Enthusiast Forums


Mazda3 Offered in both a sedan and wagon, this sporty model offers a great car for the family, as well a fun track car.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-19-2017, 12:00 AM
Junior Member
Thread Starter
 
Join Date: May 2017
Location: Connecticut
Posts: 2
Default 2010 iT works, and then doesn't? Frustrating.

I have a 2010 Mazda3 i Touring Sedan with 79,000 miles on it, and during the snowstorm, the shield under my car broke off partially, and I had to get it removed.

I had my serpentine belt replaced, but then had to send it back in for the A/C and got that fixed. Now these lights are all on, and the car seems like the transmission is slipping.

However, sometimes the lights go off, and the car is fine for a day or so. Mechanic said everything was fine when it was returned, but this happened a day later.


Last edited by cutiebud; 05-20-2017 at 04:53 PM. Reason: Remove useless information
Reply With Quote
  #2  
Old 05-21-2017, 05:42 AM
Super Moderator
 
Join Date: May 2012
Location: Queensland Australia
Posts: 2,254
Default

You will need to get a diagnostic code check done.

I'm guessing a issue with the ABS/DSC system. It could be a damaged ABS sensor/wiring on the RHF.
Early 2nd gen Mazda's 3's are also known for dodgy DSC HU/CM ( Basically the ABS pump)
Reply With Quote
  #3  
Old 05-23-2017, 01:57 PM
Junior Member
Thread Starter
 
Join Date: May 2017
Location: Connecticut
Posts: 2
Thumbs up

Quote:
Originally Posted by grim_reaper View Post
You will need to get a diagnostic code check done.

I'm guessing a issue with the ABS/DSC system. It could be a damaged ABS sensor/wiring on the RHF.
Early 2nd gen Mazda's 3's are also known for dodgy DSC HU/CM ( Basically the ABS pump)
Thank you so much. I work from home and driving the car scares me when it's skipping around (it feels like it doesn't want to go into 2nd gear now) but I will get to autozone here to check the codes immediately.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
frustrating no start condition ttommy Mazda Protege 7 12-08-2013 10:08 AM
A/C only works when 2010 Mazda CX7 is cold Almaz Mazda CX-7 0 09-03-2012 02:51 AM
Truck died and next day it works TANK1 Mazda Pickup Trucks 2 05-22-2011 04:47 PM
Why doesn't the 2010 Speed3 come with HID headlights or LED tailights? Lev Mazda3 0 09-17-2009 10:35 PM
How Lumbar Support Works and Why It Stinks pkeddie Mazda6 3 07-10-2006 12:04 AM


Tags
automatic, check, engine, sensor, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 05:03 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.