Mazda3 Offered in both a sedan and wagon, this sporty model offers a great car for the family, as well a fun track car.

*Problem*Stereo display and stereo lights not lit

  #1  
Old 10-07-2006, 02:34 AM
Junior Member
Thread Starter
Join Date: Jul 2006
Posts: 24
Default *Problem*Stereo display and stereo lights not lit

Hey guys, I gotta problem a brewin. Tonight drivin home from work I stopped at the store, came back out, turned my car on and the sterteo display and all stereo buttons were not lit up. I turned my headlight switch from auto to off and back to auto and the stereo lights came back on. While the lights were not working the cd continued to play just like normal.

So, I know it's not a fuse because they came back on with a "off then on" with the switch.
My car's a 2004 with 43,000 Kms 5sp hatch.
I just had the car in yesterday for a free oil change at the dealer and while it was there I mentioned not getting great mileage and the guy at the service counter said he would see if there were any updates. I assume he meant for the ECM, or ECU or whatever it's called. When i picked up the car he said they did the oil change and replaced some air filter kit under warranty. I never thought of the fuel mileage question and what they may have done but there was nothin on the work order about it, just the lube job and A/C filter change. So I went and jumped in my car(at the dealership), started it and immediately notice my trip A and B are both set back to 0 and my radio stations are set differently from what I have them set at plus my stereo presets(bass,treble,etc...) are all back to defaults, plus the car was revving at about 1200 until it was warmed up( I don't think it revved that high before but I cannot recall what it used to idle at when cold but it was under 1000 I think). I assumed at the time that they did load/reload some new software or update or something to address the fuel mileage issue and never thought nothing of it. That is until my stereo lights stopped working tonight.
Anyone have any insight or an educated guess? I am meeting with the owner of the dealership for a whole other issue on Tuesday and that would be a good time to bring it up I spose.

Here is a pic I took with my phone before i switched the lights off and on again. Notice that the only lights on are the temp control down below and the hazard light switch is lit up, plus all the speedo lights are fine. Only the stereo display and stereo buttons are not lit.

sorry, i attached the same pic twice. Anyway, while I took that pic the cd was playinaway just fine and I could still see the numbers and stuff on the display, it just wasn't lit up.

[IMG]local://upfiles/5361/DD266233DDE34DA1AF4A695A89221D61.jpg[/IMG]
 
  #2  
Old 05-13-2012, 10:24 PM
Junior Member
Join Date: Jan 2012
Posts: 6
Default

hey i have the same problem for as long as i can remember still no idea whats going on. they are off whenever my headlights go on. and when i turn my headlights off they go back on. sometimes very rarely the headlights will be on and then my stero lights will be working. and i think your picture isnt working but is this what you mean? this was the picture i took from my phone in my car. its an '06 m3


this is how it always looks.




and this is how it is supposed to look
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BobR
Mazda Millenia
0
08-19-2010 09:53 PM
wineye
Mazda MPV
0
11-03-2007 04:37 PM
PHARARD
Mazda Millenia
0
06-14-2007 04:00 PM
robind1
Mazda RX-7
1
08-01-2006 08:58 PM
robind1
General Tech
0
07-25-2006 04:39 PM


Thread Tools
Search this Thread
Quick Reply: *Problem*Stereo display and stereo lights not lit


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.