Mazda Tribute This low-priced SUV allows the driver the versatility of an SUV without the big fuel bill of many of the vehicles in the SUV class.

Tribute 2001 - Battery light always on.

  #1  
Old 03-04-2019, 03:20 PM
Junior Member
Thread Starter
Join Date: Mar 2019
Location: Lusaka
Posts: 3
Default Tribute 2001 - Battery light always on.

My 2001 Tribute has its battery light always on as if the battery is faulty or its not charging. Funny enough charging is just okay/normal.
have tried changing batteries, changing voltage regulator in the alternator, Checked all fuses but the light still on whenever the engine is running.
Anyone who has encountered.this problem & the possible remedy...
 
  #2  
Old 03-04-2019, 05:36 PM
simonsi's Avatar
Senior Member
Join Date: Dec 2016
Location: Auckland
Posts: 188
Default

Originally Posted by Chibi Kala View Post
My 2001 Tribute has its battery light always on as if the battery is faulty or its not charging. Funny enough charging is just okay/normal.
have tried changing batteries, changing voltage regulator in the alternator, Checked all fuses but the light still on whenever the engine is running.
Anyone who has encountered.this problem & the possible remedy...
You possibly have a short to ground somewhere on the wire between the alt and the warning light. Check for damage/chafing to the wire along its full length.
 
  #3  
Old 03-04-2019, 09:59 PM
Junior Member
Thread Starter
Join Date: Mar 2019
Location: Lusaka
Posts: 3
Default

Originally Posted by simonsi View Post
You possibly have a short to ground somewhere on the wire between the alt and the warning light. Check for damage/chafing to the wire along its full length.
I did try to check for naked wires on the harness but could not find any, also tried to clean the 2 main wire (+ & -) in the fuse box but still more.
So been wondering, the relay controlling the alternator in the fuse box, can't it be cause? How do those relays wear out?
 
  #4  
Old 03-04-2019, 10:42 PM
simonsi's Avatar
Senior Member
Join Date: Dec 2016
Location: Auckland
Posts: 188
Default

Originally Posted by Chibi Kala View Post
I did try to check for naked wires on the harness but could not find any, also tried to clean the 2 main wire (+ & -) in the fuse box but still more.
So been wondering, the relay controlling the alternator in the fuse box, can't it be cause? How do those relays wear out?
Which relay would that be? AFAIK all the alternator control is onboard the alt...
 
  #5  
Old 03-06-2019, 07:57 AM
Junior Member
Thread Starter
Join Date: Mar 2019
Location: Lusaka
Posts: 3
Default

Originally Posted by simonsi View Post
Which relay would that be? AFAIK all the alternator control is onboard the alt...
I actually meant to say a fuse...
 
  #6  
Old 03-06-2019, 11:25 AM
simonsi's Avatar
Senior Member
Join Date: Dec 2016
Location: Auckland
Posts: 188
Default

Originally Posted by Chibi Kala View Post
I actually meant to say a fuse...
Ah - no, if those connections are clean and tight and the main fuse is intact there isnt anything to wear out there.

Is the battery light on solid or does it come and go?

What was changed on the alt when you say the regulator was changed?
 

Last edited by simonsi; 03-06-2019 at 11:28 AM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Sporefrog
General Tech
0
07-25-2016 05:02 PM
BUBBA87
Mazda6
1
08-28-2014 09:35 AM
GopherInWI
Mazda Protege
8
03-17-2013 10:26 PM
gav
Mazda Tribute
9
10-04-2011 04:21 PM
oOWrvOo
Mazda Millenia
2
03-16-2008 02:08 PM


Thread Tools
Search this Thread
Quick Reply: Tribute 2001 - Battery light always on.


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.