Mazda MPV This minivan was among the class leaders with its roomy interior and efficient powertrain.

Dash Lights and Gauges blowing fuse?

  #1  
Old 01-17-2019, 09:55 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Location: Christchurch
Posts: 4
Unhappy Dash Lights and Gauges blowing fuse?

Just brought a secondhand 2003 Mazda MPV after a week the dash lights and gauges stopped going. Found the fuse replaced it all good for three weeks then blew again, now every time I replace the fuse it blows instantly the moment I turn on Ignition. Also when driving with the fuse blown the indicators don't work. Tail lights, Hazards all work. Got me stumped..
 
  #2  
Old 01-18-2019, 04:12 AM
Super Moderator
Join Date: May 2012
Location: Queensland Australia
Posts: 3,528
Default

Have you touched any wiring or fitted any accessories lately? Has the stereo been touched?
 
  #3  
Old 01-18-2019, 02:57 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Location: Christchurch
Posts: 4
Default

Originally Posted by grim_reaper View Post
Have you touched any wiring or fitted any accessories lately? Has the stereo been touched?
No i havent touched anything it has an after market stereo fitted, that works fine. i notice that the transmission selector lockes in park if the fuse is blown. the distance travelled between the time the first fuse blew and now was about 600kilometers
 
  #4  
Old 01-18-2019, 08:33 PM
Super Moderator
Join Date: May 2012
Location: Queensland Australia
Posts: 3,528
Default

Which exact fuse is blowing?
 
  #5  
Old 01-19-2019, 12:33 AM
Junior Member
Thread Starter
Join Date: Jan 2019
Location: Christchurch
Posts: 4
Default

A 15amp fuse titled Meter in the fuse box in the passengers foot well. its a right hand drive new zealand vehicle.
 
  #6  
Old 01-21-2019, 02:47 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Location: Christchurch
Posts: 4
Red face Solved I think??

Just to complicate this issue further, I disconnected the battery for a couple of hours, reconnected it, replaced the fuse and bingo dash lights and gauges working again, transmission lever not locking in park. With no blowing of fuse. Now wondering if this is an issue connected to the computer? or some sensor shorting? Got me stumped.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ransack
Mazda RX-7
3
01-20-2011 09:08 AM
anthonytsi
Mazda 323,Mazda 626 & Mazda 929
0
11-12-2008 04:37 PM
jealousonesenvy
Mazda Pickup Trucks
3
06-25-2008 05:22 PM
Hunter2215
Mazda Protege
5
05-12-2007 02:18 PM


Thread Tools
Search this Thread
Quick Reply: Dash Lights and Gauges blowing fuse?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.