Mazda MPV This minivan was among the class leaders with its roomy interior and efficient powertrain.

97 MPV Runs rough!

  #1  
Old 03-11-2009, 02:55 PM
Junior Member
Thread Starter
Join Date: Mar 2009
Posts: 3
Default 97 MPV Runs rough!

I have a 97 MPV, 3.0, that suddenly started missing and barely running when you try and advance the throttle normally (if you very slowly advance the throttle you can get full RPM's). The CEL light comes on sometimes then goes out. I got a #P1455 code out of it. I bought this van used and with pretty high miles (180,000) and in 10,000 miles it never skipped a beat or used any fluids, this happened this happen when I started to apply throttle after going down a pretty long hill, ran good at the top and barely at the bottom. I checked the ignition and valve timing, compression, changed the plugs, rotor, distributor cap, TPS, battery, and fuel filter. any help would be greatly appreciated.
 
  #2  
Old 04-02-2009, 11:31 AM
Junior Member
Join Date: Apr 2009
Posts: 2
Wink 97 MPV Runs rough! - Replace Plugs and Wires?

I had a very similiar issue with my 98 MPV. New Spark plugs and Wires helped.

Everything was good, then one foggy morning, it would just barely start after much trying, and ran worse if it started. I could smell fuel, and it hit occasionally, but mostly would not start. When it started, I could not push the throttle without huge backfires and gagging engine. It was weird that I could slowly go up to the red line, but not hit the throttle at all or it would stall.

After a couple of trips to check the codes now lighting my check engine light (after replacing a missing bulb), I got misfires and bad o2 sensor. Long, frustrating time and I replaced the wires and plugs because they were old anyway, and the problem was gone. I replaced the front o2 sensor, but it looks like the code P0141 is heater in the REAR sensor. Good news is they are the same sensor, and I am going to check the wires and if that does not help, put the old front sensor into the back hole and adapt the wires.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
wgorham
Mazda Millenia
0
07-09-2008 12:36 AM
tribute owner
General Tech
4
06-03-2008 10:27 AM
dove
General Tech
0
04-24-2008 09:37 AM
SLSB2200
Mazda Pickup Trucks
0
02-26-2008 12:10 PM
jimm
Mazda MX-3 and Mazda MX-6
13
12-14-2005 11:28 PM


Thread Tools
Search this Thread
Quick Reply: 97 MPV Runs rough!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.