heater/blower motor runs only after car is warmed up suggestions? - Mazda Forum - Mazda Enthusiast Forums


General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-26-2017, 08:10 AM
Junior Member
Thread Starter
 
Join Date: Jan 2017
Location: Boston
Posts: 8
Question heater/blower motor runs only after car is warmed up suggestions?

Hi
heater/blower motor runs only after the car is warmed up any suggestions?

Basically, the blower motor does not start until car warm-ups (takes 5 - 10 minutes when outside is around 0 celsius ) and after the car/engine warm-up, it works absolutely normal. I can turn it off and start again and it will work instantly but as soon it cools down I need warm up the engine, it used to work instantly even when outside was -20 celsius. I have replaced the blower motor resistor (100$) but it did not help. The issue still persists.
Does anyone be able to pinpoint the issue?
I would really really appreciate some help with it!!!!
The car has climate control A/C.
Reply With Quote
  #2  
Old 01-26-2017, 10:03 AM
Junior Member
 
Join Date: Nov 2016
Location: CALGARY
Posts: 13
Default

Have u checked the heater hoses plugged ?
or coolant level
Reply With Quote
  #3  
Old 01-26-2017, 01:11 PM
Junior Member
Thread Starter
 
Join Date: Jan 2017
Location: Boston
Posts: 8
Default

Quote:
Originally Posted by ali-bumpmazda View Post
Have u checked the heater hoses plugged ?
or coolant level
Have not done it yet but will do later today. But just to clarify, the heat comes through the vent almost right away, it just not blowing. And I tried on change automatic A/C to manual and adjust the blower speed manually - no result. But my dashboard displays does reflect mine chose. After 10 minutes of engine warm up, everything is back to normal.
Reply With Quote
  #4  
Old 01-27-2017, 07:05 AM
Junior Member
Thread Starter
 
Join Date: Jan 2017
Location: Boston
Posts: 8
Lightbulb

Quote:
Originally Posted by ali-bumpmazda View Post
Have u checked the heater hoses plugged ?
or coolant level
everything seems OK.

Just to clarify, the issue is not the heat. The issue is the blower motor does not start until the engine is warmed up which is abnormal behavior.
PS. newer cars with a push button start may not let to start the blow motor without engine due to design but older cars (mine 9 years old) should allow to turn the key half way and have radio and other electric stuff work (including blow motor).
Reply With Quote
  #5  
Old 02-04-2017, 11:38 AM
Junior Member
Thread Starter
 
Join Date: Jan 2017
Location: Boston
Posts: 8
Default

It looks like my next bet is the blower motor relay (I tried to heat the relay box with a hair blower and it helps blower to start almost instantly).

Can anyone help me locate the blower motor relay?
I did find some info in the manual but it is very confusing and has no information on the relays location.
In particular, I need to replace motor blower relay for Mazda CX7 (most likely it is the same for Mazda CX9 and Mazda 6).
Your help will be greatly appreciated.
Attached Thumbnails
heater/blower motor runs only after car is warmed up suggestions?-mazda-cx-7-fuse-relay-box-diagram.jpg  
Reply With Quote
  #6  
Old 02-04-2017, 05:53 PM
Junior Member
Thread Starter
 
Join Date: Jan 2017
Location: Boston
Posts: 8
Default

Hi, for anyone experiencing the same issue - it was fixed with appropriate relay replacement - you do not have to get original, I got mine from the hardware store for 5 bucks. Just make sure the pins have the same pattern and it rated 12v (99% relays works the same way so see diagram on the original one and check on the new one).
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help!!! "Dead" miss after car is warmed up memphis2857 Mazda RX-8 1 03-21-2012 11:27 AM
Blower only runs on high ledzep244 Mazda Protege 4 01-27-2008 12:40 PM
Truck runs until warmed up then stalls akl Mazda Pickup Trucks 4 01-18-2007 11:35 PM
heater blower motor wrecks74 Mazda Pickup Trucks 3 01-18-2007 02:45 AM
My Heater Blower Motor Quit??? Mazdaboy2600i Mazda Pickup Trucks 2 02-14-2006 01:02 AM


Tags
blower, heater, motor, resistor

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 12:29 PM.