Go Back   Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda Protege
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-13-2007, 12:01 AM
 
Join Date: Dec 2007
Posts: 2
Default P1195 Code EGR Boost Sensor Circuit fix

Hello. Well I fixed the problem with the sensors not showing up as ready however, I would like to know if anyone knows the fixs for a P1195 error. The CEL is coming on now that the sensors are finally working and I was hoping a master tech or someone who has the flow chart could possibly let me know how to fix the error. I've searched around and most answers include cleaning the valve off a bit and I've book marked those pages but if anyone else has any insight, please let me know.
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 12-14-2007, 01:35 AM
Senior Member
 
Join Date: Mar 2007
Posts: 282
Default RE: P1195 Code EGR Boost Sensor Circuit fix

http://www.mazdaforum.com/m_36162/mpage_2/key_/tm.htm
check out the fixes in the link above. This is a pain in the but job, but you need to do it. If this doesn't help, go to the junkyard and get a egr boost sensor and a solenoid. They won't charge you much.
__________________
CS
Reply With Quote
Old 12-14-2007, 01:35 AM
 
 
 
Reply

Tags
boost, circuit, code, egr, error, mazda, miata, millenia, mpv, mx6, p1195, required, sensor, solenoid, tribute, valve


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Med Center Mazda
Pelham, AL 35235


All times are GMT -5. The time now is 09:39 PM.

Internet Brands, Inc.