Mazda Forum - Mazda Enthusiast Forums - Search Results


Showing results 1 to 23 of 23
Search took 0.01 seconds.
Search: Posts Made By: perjmolsen
Forum: Mazda MX-3 and Mazda MX-6 08-02-2017, 03:58 PM
Replies: 1
Views: 838
Posted By perjmolsen
Thermostat test

I might have figured out what the problem where...

I pulled out the thermostat and tested it in some 85 degree Celsius hot water and it only opens 2 mm, according to the manual it must be 10...
Forum: Mazda MX-3 and Mazda MX-6 08-02-2017, 08:03 AM
Replies: 1
Views: 838
Posted By perjmolsen
MX3 V6 cooling liquid bubbling in overflow tank when hot

Hi

I have a Mazda MX3 V6 how has a strange issue

When the car is hot i can hear the cooling liquid bubbeling in the overflow tank, and the tank is almost full.

(when the car is cold the...
Forum: Mazda MX-3 and Mazda MX-6 04-12-2017, 04:49 AM
Replies: 0
Views: 487
Posted By perjmolsen
MX3 V6 leaks oil at EGR valve

Hi

I have a MX3 V6 who leaks a bit oil at the EGR valve, can it be caused by bad valve seals? there is a bit of blue smoke when running down hill and i give it some pedal.

If not is there a tip...
Forum: Mazda MX-3 and Mazda MX-6 11-25-2015, 08:02 AM
Replies: 2
Views: 977
Posted By perjmolsen
Hi Did you get it solved?

Hi


Did you get it solved?
Forum: Mazda MX-3 and Mazda MX-6 11-25-2015, 08:01 AM
Replies: 4
Views: 2,743
Posted By perjmolsen
Hi Do you still have the pictures?

Hi


Do you still have the pictures?
Forum: Mazda MX-3 and Mazda MX-6 11-25-2015, 01:57 AM
Replies: 1
Views: 760
Posted By perjmolsen
Lack of power - only when turning sharp right!

Hi


I have a strange problem with my Mazda MX3 V6 from 1994


When I driving the car and make a sharp right turn, the car loses power.
The RPM drops to 0 - then I press/pump the speeder and...
Forum: Mazda MX-3 and Mazda MX-6 10-07-2015, 02:25 AM
Replies: 1
Views: 687
Posted By perjmolsen
Hi I have had the car to a shop, they...

Hi


I have had the car to a shop, they have made a compression test, all cylinders is fine, they also said that it is the valve stem who is the problem.


Now I just need to find a set for my...
Forum: Mazda MX-3 and Mazda MX-6 10-06-2015, 06:53 AM
Replies: 1
Views: 687
Posted By perjmolsen
Engine burning oil - valve seal

Hi


I have a Mx3 V6 1.8 from 1994


When i start the car, a blue smoke from the exhaust.
There is also blue smoke when i use the engine breake down hill and give it some gas.
Forum: Mazda MX-3 and Mazda MX-6 03-05-2015, 07:24 AM
Replies: 1
Views: 552
Posted By perjmolsen
Installation of new brake dust sheelds

Hi


I am restoring a Mazda MX3 - and I have ran into some problems.


How do I change the brake dust sheelds in front and rear?
I guess that I need to pull the hub out.
Forum: Mazda MX-3 and Mazda MX-6 12-04-2014, 02:59 AM
Replies: 3
Views: 969
Posted By perjmolsen
Low idle on MX3 - V6 year 1994

Hi

I have a problem, when the car is hot is has low idle rpm's

I have tried to adjust idle air screw, but I am unable to make the rpm higher, I can hear that it takes more air in thru the...
Forum: Mazda MX-3 and Mazda MX-6 11-27-2014, 01:56 PM
Replies: 0
Views: 874
Posted By perjmolsen
HEI mod on Mazda MX-3 v6

Hi


I have a question abaut the HEI mod that i have found a guide to here:
ProjectMazda :: HEI Ignition Module install (http://www.clubprotege.com/wil/howto/hei/)


In the guide they are...
Forum: Mazda MX-3 and Mazda MX-6 11-27-2014, 02:58 AM
Replies: 7
Views: 830
Posted By perjmolsen
Ok - I where afraid of that I could have done...

Ok - I where afraid of that I could have done something wrong :)
Forum: Mazda MX-3 and Mazda MX-6 11-26-2014, 11:14 AM
Replies: 7
Views: 830
Posted By perjmolsen
Hi Hixx and Tanprotege It seems that the...

Hi Hixx and Tanprotege


It seems that the new distributor i got is bad :(((


There is no spark at all


I have installed the old distributor to see if there is spark, and there is (and...
Forum: Mazda MX-3 and Mazda MX-6 11-26-2014, 02:36 AM
Replies: 7
Views: 830
Posted By perjmolsen
Hi I will check that when I come home from...

Hi

I will check that when I come home from work.
I tried to fire it up yesterday when it where cold, it did not fire up.

It seems like there is ignition, I will check the fuel pressure and...
Forum: Mazda MX-3 and Mazda MX-6 11-25-2014, 02:12 PM
Replies: 7
Views: 830
Posted By perjmolsen
MX-3 v6 Unable to start when hot

Hi


I have installed a new distributor in my Mazda Mx-3, and i solved the error 3 code, and it now fires and run, it ran a bit rough when it where warmed up at idle, but i adjusted the idle screw...
Forum: Mazda MX-3 and Mazda MX-6 11-19-2014, 01:22 PM
Replies: 10
Views: 4,153
Posted By perjmolsen
Hi Its a Mazda Mx3 from 1994 ...

Hi


Its a Mazda Mx3 from 1994




I think that the cam sensor is inside the distributor
Forum: Mazda MX-3 and Mazda MX-6 11-19-2014, 11:32 AM
Replies: 10
Views: 4,153
Posted By perjmolsen
Hi Sorry for the late answer, but I have...

Hi


Sorry for the late answer, but I have been busy faultfinding.
I have found out of what I taught where a CEL/MIL light where a indicator for missing washer fluid :(


I have made a wire...
Forum: Mazda MX-3 and Mazda MX-6 11-12-2014, 07:06 AM
Replies: 10
Views: 4,153
Posted By perjmolsen
Hi I just noticed something more -...

Hi


I just noticed something more - under the dash there where a relay marked "H270" what are that relay for? (It has a burned connector)


See picture below "faulty relay.jpg"

...
Forum: Mazda MX-3 and Mazda MX-6 11-12-2014, 04:47 AM
Replies: 10
Views: 4,153
Posted By perjmolsen
HI I have tried to unplug the MAF and...

HI


I have tried to unplug the MAF and start the engine, it where the same running poorly.
I try to check for leaks later today, and also clean the MAF with a electronic cleaner, and let I dry...
Forum: Mazda MX-3 and Mazda MX-6 11-11-2014, 01:41 PM
Replies: 10
Views: 4,153
Posted By perjmolsen
Hi Tanks for your help :) Today...

Hi


Tanks for your help :)


Today I come a bit closer - I managed to get it running, but I where hard to start, It seems that it is getting a lot of fuel. I where able to start the engine by...
Forum: Mazda MX-3 and Mazda MX-6 11-10-2014, 07:04 AM
Replies: 10
Views: 4,153
Posted By perjmolsen
Removed alarm and now i cant start the car

Hi


I got a Mazda Mx3 who had a Cargard 350S alarm installed.


I did not have the remotes, so when I tried to start the car it cranked slowly - It where the alarm who got the car to crank...
Forum: Mazda MX-3 and Mazda MX-6 11-09-2014, 10:04 AM
Replies: 2
Views: 2,510
Posted By perjmolsen
Hi I have now get the car to crank...

Hi


I have now get the car to crank normal, but I got a new problem.


The reason for the slow crank where that the previous owner had installed a alarm, bullgard 950s


When I removed the...
Forum: Mazda MX-3 and Mazda MX-6 11-07-2014, 03:35 PM
Replies: 2
Views: 2,510
Posted By perjmolsen
Mx3 does not start after washing engine bay - crank slowly

Hi
I have bought a Mazda MX3, the guy that I have bought it from has washed the engine bay with a pressure washer :? and after that the car coud not start.
He has also taken the radio out. Is...
Showing results 1 to 23 of 23

 
Forum Jump
Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 07:18 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.