Mazda3 Offered in both a sedan and wagon, this sporty model offers a great car for the family, as well a fun track car.

No decel after throttle clean

  #1  
Old 09-05-2018, 05:58 PM
Junior Member
Thread Starter
Join Date: Sep 2018
Location: Colorado
Posts: 2
Default No decel after throttle clean

Hey guys I have researched list and been dealing with it for over a year. After one day of cleaning the throttle body, I hop in the car, start driving, and in between shifting manually it sounds like I'm not letting off the throttle. I'm finally just fed up with it I can't deal with this anymore I need this fixed. I've heard of many forms of guys bringing their cars into dealers and they have no clue what's going on, others say it's your O2 sensor, then more say oh you just need to reset your ECU, then other say just give it time it'll reset itself.

Well I have reset my ECU at least 45 times( battery off ECU plugs completely disconnected) I have taking my throttle body off an additional five or six times to make sure everything went on correctly in sealed, I have done voltage and scope test every signal coming out of it, there are no imperfections in the signal that I could see.

So you get once you clean it you're letting more air in, but mine was not that dirty at all. I'm talking. 001 - . 002 of debris. So I am astonished that this is caused this issue. Now they also say make sure you don't get brake cleaner or carpet cleaner near the edges of the bar, now I have taken it apart and I have no clue why that would matter.... Is sensor 1 is an enclosed and 2 quite a ways away from the entrance of that borehole. Three it's just a potentiometer. so it's just a whole bunch of contacts as this thing spins around I don't know how brake cleaner can affect that working. And as I said earlier I'm not getting any imperfections on my oscilloscope testing.

So if anyone has any knowledge of someone having this issue and finally fixing it, pretty much every issue I brought up in this post has not worked at all more than once more than twice. As well I also have zero engine codes, I did have both O2's reading bad so I replaced thinking that would help and it did not after driving for 4 months with three resets in between.

So please guys I'm desperate here. why I'm so desperate is this is also on Haltech 750cc injectors 11.5psi 300whp. So when I drive this I have to drive in manual otherwise my training will go poof'''.. so when I drive this thing I sound like a f**king retard.

Also know that I brought up this thing has modifications to it please do not let that affect your opinion on this being an issue with the car itself and not anything I have done, my drive by wire is being driven by the stock ECU. Not only that I drove this at 300 horsepower for 6 months perfectly. Just decided to clean a throttle body one day in band here we are a year later and it sounds like it's my first day in a stick. Lol
 
  #2  
Old 09-06-2018, 10:20 AM
Member
Join Date: Jan 2017
Location: Greenwood, SC
Posts: 56
Default

Questions:
What is your warm idle speed?
How are you increasing fuel for boost with a stock ECU?
Fuel rail pressure increase?
Can you confirm the ECU is running in closed-loop mode (not cold mode)?
Do you have a AF gauge that is accurate?
Does it run 100% normally otherwise?

My first guess is an injector problem or excessive fuel rail pressure.

RGAZ
 
  #3  
Old 09-17-2018, 09:11 PM
Junior Member
Thread Starter
Join Date: Sep 2018
Location: Colorado
Posts: 2
Default

Warm idle speed is around 700

I mentioned im running Haltech which is a standalone ecu. I am running them in tadem. Stock runs trans and drive by wire, Haltech runs fuel and ignition and cam advance.

Im also on E85, even during the 6 months everything was gravy.

Running a fuel return setup, -6 line running from inside fuel tank straight to walbro255i to filter then custom fuel rail, old fuel sending line is now return line. fuel regulator 43.5psi with no vacuum which is a very standard pressure setup, 3 bar...

closed loop or open shouldn't matter during idle since Haltech is controlling that. But I have tried running open loop with stft off. That has no effect.

Using a aem wideband, very accurate.

Honestly I have tried screwing with every setting on Haltech it makes no difference other then the bandade I made. I run my TPS reading off the pedal now instead of the true tps posssition, that way Haltech can see when I let off the pedal and I turned on decel, so this way I let off throttle the haltech ECU actually sees 0% throttle and will activate decel, which is just fuel cut. When I do this it's way better cuz even tho my true tps position is 20% during zero pedal input between shifts. But activating decel makes me at least decel, still not as good as true tps at zero (well 2-6% dbw controls idle).

But yeah im telling u, ur steering ur thinking into other things. You have to remember this all ran perfectly! For 6 months, took one clamp off, one coupler 4 bolts and used brake cleaner and a rag. Assembled it back together and this started. I first thought gasket issue, put new in, same problem.

So absolutely nothing was changed on this car, I literally unbolted this throttle body, cleaned it, and this problem arose. I didn't even plug in my laptop within weeks, so no settings were changed.

But I have read of this happening on several other Mazdas after cleaning the throttle body. So this is happened to other people after doing the exact same thing on a stock car and having the same effect. This is how I'm positive it has nothing to do with the performance parts I have added.

One of many Mazdas no decel after TB cleaning
 
  #4  
Old 09-18-2018, 10:24 AM
Member
Join Date: Jan 2017
Location: Greenwood, SC
Posts: 56
Default

Ok, very good info. Lets break it down.

Tandem ECU, Ok got it. Should not be a problem.
Fuel fine (I assume proper boost retard tables in the Haltech so good there)
Fuel pump pressure looks great, I had similar setup on my CRX so its fine.
Open loop test, no change. That is interesting and eliminates O2 sensor.
AEM wideband, good choice. I assume its reading all normal, slight rich under boost. Anything odd here I would go for injector leaker.

Your TPS setup is odd. Its not how I would do it, but if it was working before I wouldn't say its the problem. Don't mess with it until we try a couple things.

Lets go old school. Look for a vaccum leak. Engine idle, in the driveway, spray carb cleaner over all the TB parts you messed with. If the engine speeds up, you found a problem.

After that, let's repeat the Mazda ECU reset. (yeah, I know) Have the car cold. Remove battery cable for a long time. Reconnect. Now start the car and TOUCH NOTHING. Do not touch throttle, lights, radio, AC, nothing for at least 5 minutes, 10 if you can stand it. Let it literally sit there doing nothing but idling. I know you already did this, but try again. and be patient.

Now its warmed up test drive and see. Same result? Get under the hood with it idling and tap the MAF, wiggle its connector, make sure the engine does not stumble. Same for TB servo, tap it. Listen for stumble. gently tug each wire into MAF connector. Something you disturbed during the cleaning has caused this, so push/pull/move anything you touched.

This one is an odd one.

Does it do it the same way with AC on and off? Now I am reaching...

This is really a gremlin.

RGAZ
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
madmike01uk
Mazda5
6
01-08-2013 11:15 AM
MazdaTirol
Mazda 323,Mazda 626 & Mazda 929
11
08-28-2012 11:28 AM
tazman
New Member Area
6
04-19-2006 10:04 PM
EZE
Mazda3
6
10-24-2005 04:55 PM
babyhuey
Off Topic
2
09-02-2005 02:11 AM


Thread Tools
Search this Thread
Quick Reply: No decel after throttle clean


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.