Mazda Protege This compact model offers an economical solution for the need for a sporty sedan or wagon.

2000 - P0106 map sensor, sputtering issues

  #1  
Old 11-17-2017, 12:28 AM
Junior Member
Thread Starter
Join Date: Nov 2017
Location: Ontario
Posts: 1
Default 2000 - P0106 map sensor, sputtering issues

I posted this earlier elsewhere after soaking up as much knowledge as I could about this problem so apologies if there's a bunch of ideas.

It occasionally throws a P0106, right now it is not. At idle or low speeds, the rpms will sputter, which of course means exhaust sputter at the back, and lights inside and out dimming. When listening to the intake, it sounds like it is burping, or gasping for air occasionally. Starting takes quite a few cranks, used to be instant.

Side note: I replaced the 90 degree exhaust pipe (that has the o2 sensor) that goes from bottom of cat to the spring connection that joins the rest of the pipe a few months ago. It must not have liked my splice, or maybe the sensor is broken, as it's been throwing P0140 since. I read this doesn't matter since it's there for emissions and has no effect on the car as it's downstream of the cat.

Today I took the EGR out and apart, and while I wasn't able to clean it, inspection looked good. Someone suggested that this port where the hose connects to the manifold gets clogged, mine was completely blocked with carbon so I cleaned it out, but that did not fix the idle issues. I just checked the hose that connects the map sensor to the intake manifold at the EGR (the clogged one) and it is clear. Could the port inside the intake manifold be clogged? Checking that would mean taking the throttle body off, can I check the pressure without the proper gauge somehow at the map sensor end?

I've read suggestions to clean the MAF sensor. I recall taking it out of the intake tube before and it seemed very small and I'm not sure what would need cleaning. But the code isn't for the MAF sensor but for the map sensor so this shouldn't matter anyways?

If the above is not it, would a vacuum leak be the next probable cause? Tomorrow I will also inspect all the lines.
 

Last edited by wsg14; 11-17-2017 at 12:40 AM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
oguzakyuz
Mazda Millenia
17
05-01-2016 12:07 PM
babyhuey
Mazda MPV
3
09-18-2012 03:57 AM
crunion
Mazda MPV
2
05-17-2010 04:04 AM
eNSGriffin2917
Mazda Protege
1
03-25-2008 08:09 AM
gangst
Mazda Protege
16
02-22-2008 08:42 PM


Thread Tools
Search this Thread
Quick Reply: 2000 - P0106 map sensor, sputtering issues


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.