Unplugged sensor not killing engine - Mazda Forum - Mazda Enthusiast Forums

Go Back  Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda Pickup Trucks
Reload this Page >

Unplugged sensor not killing engine

Mazda Pickup Trucks While Mazda may not be known for their trucks, they have always produced quality reliable trucks for both hauling cargo, or simply crusing.

Unplugged sensor not killing engine

Reply

 
 
 
  #1  
Old 08-06-2017, 11:07 AM
Junior Member
Thread Starter
Join Date: May 2015
Location: Texas
Posts: 29
Default Unplugged sensor not killing engine

93 B2600I 5spd. I checked online for ways to check the maf sensor and one claimed to have your engine running then unplug the sensor, if it died then sensor was fine but if it kept running it was bad. Does anyone have any experience on this because my engine did keep running although a little rough then I turned it off then started the engine again with the sensor unplugged. I have already cleaned the sensor using lots of maf cleaner.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Malachi Subbert
Mazda Pickup Trucks
1
05-16-2013 09:24 AM
pdjafari
General Tech
4
11-18-2007 12:27 AM
MazdaSilva
Mazda Millenia
0
11-17-2007 10:57 PM
hannster30
Mazda Protege
6
04-01-2007 08:18 PM
Plshelpme
General Tech
3
09-01-2005 05:39 AM


Thread Tools
Search this Thread
Quick Reply: Unplugged sensor not killing engine


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.