Mazda MPV This minivan was among the class leaders with its roomy interior and efficient powertrain.

2002 MPV Emissions

  #1  
Old 09-14-2009, 03:32 PM
Junior Member
Thread Starter
Join Date: Sep 2009
Posts: 2
Default 2002 MPV Emissions

I have a 2002 MPV. The CEL was lit and the scan tool revealed P031 & P037. I replaced the O2 sensors for bank 1 sensors 1 & 2 with the Bosch aftermarket sensors. Well I got the CEL to come off but I can't get two of the monitors to reset after drive cycles. I also have a pending P0431 that hasn't lit the CEL. I can't get the EVAP and CAT monitor to reset and I can't pass emissions.

I have driven the drive cycles specified in the service manual and EVAP and CAT are the two I can't get to reset. I can understand the CAT not resetiing wit the pending P0431, but I don't now why the EVAP monitor won't reset. According to Baby Huey a pending DTC should not affect the reset on another system.

So if anyone can tell me:

1. Why I am getting the pending P0431 after O2 sensor replacement(but not before).
2. Why I can't get the EVAP monitor to reset after Mode 6 drive cycle?

I wold appreciate it very much
 
  #2  
Old 10-03-2009, 11:23 AM
Junior Member
Join Date: Oct 2009
Posts: 1
Default

I have a 2003 mpv and have an emission code POO37 low bank 1 sensor 2 and would like to know which one that is? ( front one on the bottom ? ) aiso was the bosch aftermarket a direct replacement ordid you need to resplice wirers ?
 
  #3  
Old 10-04-2009, 12:19 PM
Junior Member
Thread Starter
Join Date: Sep 2009
Posts: 2
Default P0037 and Emissions follow-up

Check out this link it explains it better than I can for a P0037 code.
http://forum.mpvclub.com/viewtopic.php?p=108448#108448


Following up on my previous post

I fixed the P0431 with the "Spark Plug No Fouler" trick see https://www.mazdaforum.com/forum/general-tech-6/dirty-tricks-cats-19026/. This can save you over $1000

As for the monitor resets, I had to take it to the dealer. They got BOTH monitors to reset with 25 miles. I had, and drove the "drive cycles" specified in the factory service manual; but the CAT and EVAP would not reset. So something tells me I was missing something. If anyone ever finds out, I would love to know.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mrclever
Mazda Protege
2
11-27-2008 08:31 PM
brad_rolader
General Tech
2
08-08-2008 08:28 AM
Roleary
General Tech
6
04-25-2006 10:20 PM
1misslisa
Mazda Miata (MX-5)
7
04-15-2006 04:26 AM
inashell
General Tech
12
10-10-2005 04:53 PM


Thread Tools
Search this Thread
Quick Reply: 2002 MPV Emissions


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.