Go Back   Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda Protege
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-16-2005, 04:03 PM
 
Join Date: Jun 2005
Posts: 2
Default turn signal problem

i have a 2000 protege. having a problem with the turn signals. i have checked the fuses and they are fine. looked in the fuse box under the hood and the dash. cannot seem to find the flasher/relay for the turn signals. there is one marked for tail lights but that seems ok. i have swapped that relay out. any ideas?

thanks

w
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 06-16-2005, 05:29 PM
 
Join Date: Nov 2004
Location:
Posts: 55
Default RE: turn signal problem

check the plug for the buld connection, sometimes they get corroded and need to be cleaned, after that definately find the flasher turn signal relay, sounds stupid, but either turn the flashers on and listen for the clicking sound and try to locate the relay that way, or buy a chilton or haynes manual and find the relay that way, and replace that, you should find the solution to your problems.
__________________
89' B2200, 4.5-inch body drop, bagged, 4-linked, completely shaved, added some ponies, daily driven, and daily dragged "If sparks don't fly, you are too damn high!"
Reply With Quote
  #3  
Old 06-16-2005, 10:10 PM
 
Join Date: Jun 2005
Posts: 2
Default RE: turn signal problem

i have tried that. turned the hazards on but i cant hear the relay. its completely dead. the chilton manual doesnt show where the relay is. called the dealership, they want me to bring it in and charge me.
Reply With Quote
  #4  
Old 06-17-2005, 04:19 AM
 
Join Date: Nov 2004
Location:
Posts: 55
Default RE: turn signal problem

sorry to hear that, I will check around and get back to you hopefully sometime this morning about the location of the relay................
__________________
89' B2200, 4.5-inch body drop, bagged, 4-linked, completely shaved, added some ponies, daily driven, and daily dragged "If sparks don't fly, you are too damn high!"
Reply With Quote
  #5  
Old 09-12-2005, 11:16 AM
 
Join Date: Sep 2005
Posts: 1
Default RE: turn signal problem

Hi,
I have the same problem. I found the relay clicker it is underneath the driver side. right under your left foot. it looks like a small green retangular box. you might need to unscrew the base thats holding it. it is easier to take it off like this.
Reply With Quote
  #6  
Old 09-13-2005, 09:14 PM
Senior Member
 
Join Date: Jul 2005
Posts: 2,747
Default RE: turn signal problem

Flasher module is located on left side of drivers footwell. Is a small white/ivory colored box with a 3 wire connector. Wire colors are Black, Blue, and Purple with white stripe. Picture maybe will help also.

[IMG]local://upfiles/1377/A4968A3AA48B4C3AA7CC1D185FA03AEA.jpg[/IMG]

[IMG]local://upfiles/1377/09BA00A5EE9644ED902A4CB924C4C376.jpg[/IMG]
Reply With Quote
Old 09-13-2005, 09:14 PM
 
 
 
Reply

Tags
2000, blinker, buy, find, flasher, imglocalupfiles1377a4968a3aa48b4c3aa7cc1d185fa03ae ajpgimg, localupfiles1377a4968a3aa48b4c3aa7cc1d185fa03aeajp g, location, mazda, problem, protege, protege5, relay, signal, turn


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Med Center Mazda
Pelham, AL 35235


All times are GMT -5. The time now is 08:48 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.