Go Back   Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda Protege
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-31-2008, 02:38 PM
 
Join Date: Jan 2008
Posts: 1
Default 2002 Protege5 with engine light

ok....im new and have a 2002 mazda protege5...love it but i get a random engine ligth going on.
The local dealer told me it was "random misfire" and the cleared the code...cleaned what appeared to be water on the wires and plugs and told em if it hapened again to bring to back...
well....it happen again...when it happens..the light blinks, the car sputs like its goin to turn off but doesnt...once the light goes solid...the car drives like nothing wrong???!!!

did i get a lemon?? or is it like they said...probably the wires or plus are bad?

btw....i love this lil car...had nissan before and then a frod sporttrac and needed to get back into a lil sporty car with decent gas miles...
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 02-09-2008, 11:04 PM
 
Join Date: Feb 2008
Posts: 1
Default RE: 2002 Protege5 with engine light

I have a 2002 Protege 5 and the same "random misfire" issue. I'm driving along fine, then suddenly the check engine light starts blinking ... the car sputters and has little power ... I pull over, turn the engine off, turn it on and the car drives fine, though the check engine light stays on solid.

I took it to the dealer. They said they found a P0300 code, which they said was caused by a bad EGR Control Valve. They put a new EGR Control Valve in, but this didn't fix it. I took it back to the dealer ... they pulled the P0300 code off it again, but said they wouldn't be able to diagnose the problem unless it would happen while they were driving it with some diagnostic tool attached to give them more information.

This seems to be happening more and more frequently. About every other day now. Usually, after I've been driving about 20 minutes, though sometimes sooner. It hasn't happened yet at higher idle / higher acceleration, though this may be coincidence.

Any ideas of what could be wrong or how to diagnose what is wrong? All I feel I can do is wait for whatever is bad to break all the way, so I can find out what it is and hopefully fix it, and hope I'm not too far from a tow truck when it happens.

Thanks
Reply With Quote
  #3  
Old 02-12-2008, 10:35 AM
Junior Member
 
Join Date: Feb 2008
Posts: 12
Default RE: 2002 Protege5 with engine light

I've got a 00 protege and have had numerous problems with water in the spark plug holes. Typical signs are a miss at low engine speedcombined with aheavy load such as half to full throttle. Higher RPM's are OK. It may be that when the light finally goes solid the PCM has resorted to a "limp mode" and provides a richer fuel mixure to eliminate the miss. First make sure all wires and plugs are completely dry. Remove and dissassemble everything and blow them off with compressed air. I even spray mine with a "Wire Dryer" which is like a silicone spray (wipe off the excess). I've gotten the P0300 (Missfire), O2 Sensor, and Catalyst Efficeincy Below Threshold" because of this problem depending on how oftenthe missoccurred.

Another cause for a miss I've encountered is a dirty intake air temp sensor. In my 00 protege it's the little teardrop shaped sensor built into the MAF sensor. Remove the MAF and spray this with some carb cleaner to remove residue. Isearched for this intermittentmiss for months until it finally threw a code for the IAT sensor.
Reply With Quote
  #4  
Old 10-24-2008, 08:22 PM
Junior Member
 
Join Date: Oct 2008
Posts: 4
Default RE: 2002 Protege5 with engine light

I'm having the exact same problem with my '02 Protege5. Did you ever get any resolution with yours?

I've been having major issues. First, the mechanic replaced my spark plugs. Then, the EGR valve. The problems returned and he pulled the same code. It's a mystery...The car drives well for 20 minutes, the engine light comes on, then it sputters, the engine light starts flashing, and caput! No power, etc. But, I can restart the engine and go on my way. It's happening more frequently now (3 times today) and we're stumped.

Any information is greatly appreciated!

Thanks!
Reply With Quote
  #5  
Old 10-24-2008, 09:43 PM
Senior Member
 
Join Date: Mar 2007
Posts: 282
Default RE: 2002 Protege5 with engine light

I'd be looking at the coil packs first...
__________________
CS
Reply With Quote
  #6  
Old 10-28-2008, 01:20 AM
 
Join Date: Sep 2008
Location:
Posts: 3
Default RE: 2002 Protege5 with engine light

i have same problem, excpet no MIL. I found it using a timing light inductive pick up and was always intermittent flash on 2/3 cyl. coil pack. I swappped coil packs,a dn problem remained with the 2/3 cyl. the other coil worked proper before swapping it, so its not the pack, and i tried a new one as well.

I dont know what do do now? ive tried swapping new coil, wires, plugs, etc....and this problem WILL not go away...

any other ideas?
Reply With Quote
  #7  
Old 11-08-2008, 08:16 PM
Junior Member
 
Join Date: Oct 2008
Posts: 4
Default RE: 2002 Protege5 with engine light

Changed the coils and wires and all seems fine (it's been a week!) Fingers crossed! Thanks for the advice.
Reply With Quote
  #8  
Old 11-10-2008, 07:14 AM
 
Join Date: Nov 2008
Posts: 4
Default RE: 2002 Protege5 with engine light

I have a 2003 mazda protege. Basically its the same as the protege 5. Only main difference is the body style. I had my engine light on for months before i took a scanner to it. I had a mis fire with piston 4. I changed out my spark plugs with E3 Diamon spark plugs. I THINK i paid $37.99 (Advanced Auto Parts) so let me say the price range for them are $20-$40. I also bought spark plug wires for about 46 dollars. (carparts.com).

I also cleaned my EGR Valve. This is a main problem with all proteges. If your car stalls while stopped or feel loss of power when shifting, try cleaning your EGR valve. My girlfriend also has a 2001 protege andher engine light came on. She got the code P0171 <- i think i cant remember the numbers sorry. It meant "System to lean". Fix? Was the EGR valve. Again this is a main problem with all proteges and will cause your engine light to come and and can also cause loss of power. If you need steps on how to clean just let me know
Reply With Quote
  #9  
Old 11-10-2008, 07:20 AM
 
Join Date: Nov 2008
Posts: 4
Default RE: 2002 Protege5 with engine light

Also take in consideration it could be your MAF (mass airflow sensor). Its hooked up to your intake hose. There is a small sensor in that as well that can trip your engine light. I needed a new one and went to the junk yard and bought one for $120. The sensor in these things break all the time, according to the lady that worked at the junk yard.
Reply With Quote
  #10  
Old 12-03-2008, 05:32 PM
 
Join Date: Dec 2008
Posts: 1
Default RE: 2002 Protege5 with engine light

I have Mazda Protege 5 2002
At the beginning of the year the RPMs were going down for a second and then again up on neutral.
Then the check engine light came on.
The code was “Random multiple cylinder misfire”
When I went to the Dealer Ship they changed the EGR valve, this did not fix the issue.
At the end they said “Coil need to be changed” - after that the problem seemed to be solved.
After that the Catalyzer stopped working and they changed it for free, because the car was under 80K miles.
Now I have new issue “p0171 system too lean bank 1”, the check engine light is again on, as I am reading cleaning the MAF can solve this.
So in general my conclusion is:
The RPM are playing, the car is almost turning off, the check engine light is coming on shortly after that, this should be coil, not EGR.
Hope this helps.
Reply With Quote
Old 12-03-2008, 05:32 PM
 
 
 
Reply

Tags
2002, 626, air, blinking, check, cleaning, coil, engine, flashing, light, mazda, packs, protege, protege5, sensor


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Med Center Mazda
Pelham, AL 35235


All times are GMT -5. The time now is 12:11 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.