Tcs, tcs off, and abs light - Mazda Forum - Mazda Enthusiast Forums

Go Back   Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda Millenia

LinkBack Thread Tools Search this Thread
Old 06-10-2010, 06:03 PM
Junior Member
Join Date: Mar 2009
Posts: 10
Default Tcs, tcs off, and abs light

I have a 2000 millenia 2.5l. I started it up yesterday and my tcs, tcs off, and abs lights all stayed on. I don't notice a performance difference but I'm unsure of what kind of damage it may cause. Any advice on what I should look for? I have seen some posts that mention a vaccum leak but I'm unsure what that has to do with my braking system?
Reply With Quote
Old 06-11-2010, 07:20 AM
Senior Member
Join Date: Sep 2005
Posts: 971

when the car is started, the control unit does a series of self tests, and these are repeated during the drive cycle. if it sees a problem with the abs, then it disables it. when abs is disabled, traction control(tcs) is too, since the system needs to read off the abs sensors. start with simple fixes, like disconnect/reconnect each sensor. at the same time, examine the pickup end, which might have gotten damaged. however, if there was physical damage, the lites would have immediatly illuminated.
Reply With Quote
Old 07-11-2010, 02:45 PM
Junior Member
Join Date: Jul 2010
Posts: 1

Hello guys, first post here but have already benifited from some info today (Found a bad vacuum line related to a P0304 fault after reading some of the forum).

I am checking the wifes Millenia which is also having the same issue with the ABS and TCS lights. They come on and stay on as soon as I start the car. I have metered both sensors on the front and get transition when moving the tires which indicates to me that is not the cause.

I have also read that the ABS light may come on after a jump start due to a low battery. I have 12.2 on the battery. Any chance that it is the battery or and alternator issue? She has been off work for a while and not driing much since school ended. My next guess would be a harness problem and I have no idea where to check.

Thanks for any help and thanks for the info already provided.
Reply With Quote
Old 11-22-2010, 08:48 PM
Junior Member
Join Date: Nov 2010
Posts: 3

my 2002 mellenia s has similar issue. tcs, tcs off, and abs lights turn on but only when reaching 80mph. do not notice any performance loss and lights shut off after restart. still have not figured it out
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Milly S - ABS Brake TCS TCS Off lights on no speedo/odo Joeboost Mazda Millenia 6 04-21-2013 08:14 PM
ABS, break light, and tcs light indicators cegar Mazda 323,Mazda 626 & Mazda 929 0 10-26-2011 04:59 AM
1999 mazda millenia S TCS & TCS OFF light stays on and only 2500 RPM max thinhbui Mazda Millenia 6 11-19-2009 12:13 PM
'01 626 V6 - 73K - Abs, Tcs, Tcs Off lights jamcc Mazda 323,Mazda 626 & Mazda 929 2 12-26-2006 01:11 AM
ABS, TCS and TCS Off Light on Mazda 323 luke Mazda 323,Mazda 626 & Mazda 929 1 12-16-2005 09:30 PM

03, 2010, abs, brake, clean, control, cx7, light, lights, mazda, millenia, mpv, off, rx8, sensor, tcs, traction

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 02:28 PM.