Go Back   Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda Millenia
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-05-2010, 11:25 AM
Junior Member
 
Join Date: Oct 2010
Posts: 4
Default Engine Mechanical problem/noise

2002 mazda millenia 2.5L got loud engine noise after start up or idling. the noise seems to almost dissapear or much less noticable when rpm above 2000rpm. The car has 135K mile. check engine light on with code 0300, 0350 and 0421. Changed all spark plugs afterward. The local mechanics told me the noise seems from inside timing belt cover, front of oil pan, rear upper valve train and water pump. I read one post said bad timing belt tensioner could cause engine noise/knocking. Timing belt never replaced on this car. Can anyone kindly provide the advice or similar experience? Many thanks.
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 10-09-2010, 08:33 PM
Member
2001 Mazda Millenia
 
Join Date: Sep 2009
Location: Stanford, IL
Posts: 30
Send a message via Yahoo to ZoomZoom81
Default

Dude, do you have my car? LOL, mine's doing the SAME THING. And I was told by Mazda mechanic it's my timing belt. Which was my first instinct since the noise was right inside the belt cover. I have a 2001 2.5L and it looks like it's gonna be alot of fun putting the new one on.....not
Reply With Quote
  #3  
Old 10-10-2010, 08:14 AM
Junior Member
 
Join Date: Oct 2010
Posts: 4
Default

Thanks, ZZ81. You are right. The hydraulic tensioner has fallen apart. The problem is solved. Re set the code. Hope it won't come back. I'll see.
Reply With Quote
  #4  
Old 10-10-2010, 10:08 AM
Member
2001 Mazda Millenia
 
Join Date: Sep 2009
Location: Stanford, IL
Posts: 30
Send a message via Yahoo to ZoomZoom81
Default

So did you have to replace/fix the hydraulic tensioner or replace the timing belt? I'm trying to figure this out before I tear everything apart since you and I know what kinda hell that will be on this engine. Thanks.
Reply With Quote
  #5  
Old 10-10-2010, 12:42 PM
shipo's Avatar
Senior Member
 
Join Date: Nov 2008
Location: southern New Hampshire
Posts: 1,484
Default

Quote:
Originally Posted by ZoomZoom81 View Post
So did you have to replace/fix the hydraulic tensioner or replace the timing belt? I'm trying to figure this out before I tear everything apart since you and I know what kinda hell that will be on this engine. Thanks.
If you're going to do one, you're probably best off doing both; regardless of their relative conditions.
__________________
1998 Audi A4 2.8 Quattro 5-Speed
2009 Mazda3 i Touring Value Edition 5-Speed
2012 VW GTI 2-Door 6-Speed
Reply With Quote
  #6  
Old 10-20-2010, 11:36 AM
Junior Member
 
Join Date: Oct 2010
Posts: 1
Default

was it a loud ticking noise that would sorta speed up with the rpms till it hit 2 grand? my 95 is doing the same thing im about to start taking the engine apart today
Reply With Quote
  #7  
Old 10-21-2010, 01:48 PM
Junior Member
 
Join Date: Oct 2010
Posts: 4
Default

Quote:
Originally Posted by ZoomZoom81 View Post
So did you have to replace/fix the hydraulic tensioner or replace the timing belt? I'm trying to figure this out before I tear everything apart since you and I know what kinda hell that will be on this engine. Thanks.
I replaced the tensioner, idlers, and timing belt along with water pump. Mis-fire code is gone. I still get P0412 code, converter efficiency below threshold. At the same time, the idling speed goes up to 1500 rpm when i start up the car. I guess the mechanics may mess something up when they did the work. If anyone knows sth on this, pls let me know. thanks.
Reply With Quote
  #8  
Old 10-21-2010, 01:50 PM
Junior Member
 
Join Date: Oct 2010
Posts: 4
Default

Quote:
Originally Posted by derekoreo2004 View Post
was it a loud ticking noise that would sorta speed up with the rpms till it hit 2 grand? my 95 is doing the same thing im about to start taking the engine apart today
pretty similar like that. Above 2 grands, ticking almost dissappears.
Reply With Quote
  #9  
Old 12-04-2010, 02:33 PM
Junior Member
 
Join Date: Nov 2010
Posts: 5
Default

Any body can tell what is the total cost to replace the timming belt?
Reply With Quote
Old 12-04-2010, 02:33 PM
 
 
 
Reply

Tags
2001, 25, bad, belt, engine, loud, mazda, mechanical, millenia, millinium, noise, problem, replace, timing, valve


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Med Center Mazda
Pelham, AL 35235


All times are GMT -5. The time now is 06:15 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.