Go Back   Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda Millenia
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-19-2010, 08:46 PM
Junior Member
 
Join Date: Dec 2010
Posts: 3
Default 95 Millenia Possible Bad Fuel Pump

I own a 1995 Mazda Millenia that's a 2.5 liter V6. I started the car one day and it was running fine for a couple of minutes while in park and then the engine started sputtering as if it was running out of fuel. Now when I try to start the engine, it cranks but won't start. I can hear the two clicks from the starter and I also noticed that I can't hear the fuel pump whirring up like it should, all I hear is a click. I believe it's the fuel pump that's making the click noise because I removed the back seat cushions and listened carefully as I put the ignition in the on position. Also, I don't know what other part would make a clicking noise like that. It's just one click and it occurs when I place the ignition to the on position and when I switch it off. I'm assuming it's the fuel pump that's faulty and not the fuel pump relay because I can hear that click as if the relay is doing its job and the fuel pump is receiving voltage but just not able to pump fuel due to a mechanical problem. I am tempted to buy a replacement fuel pump tomorrow before doing more research and test but I would like some input before I shell out the money. Does this sound like a faulty fuel pump or is it difficult to tell without testing? Thanks.
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 12-21-2010, 07:46 AM
Senior Member
 
Join Date: Oct 2009
Posts: 176
Default

you would haveto get to the connector on the fuel pump and check voltage. my car (96 milly S)has three clicks,all from under the hood on the left side.two fast cliks,then another(clik,clik........clik).the last one should be the fuel pump one,but i may be wrong.the fuel pump should wine during the clicking.but if theres no voltage at the connector,it would be a relay.you might try swapping relays. relay, $15, fuel pump, priceless!!!! havent priced one lately but kinda remember the $200 range.
Reply With Quote
  #3  
Old 12-22-2010, 10:00 AM
Junior Member
 
Join Date: Dec 2010
Posts: 3
Default

Well I haven't got to test if they're is voltage to the pump but I have tried swapping relays and It didn't make a difference so I bought the fuel pump and I'm gonna try replacing it today. Hopefully she'll start after. Thanks for the help. I'll let you know if it starts.
Reply With Quote
  #4  
Old 01-02-2011, 11:52 AM
Senior Member
 
Join Date: Oct 2009
Posts: 176
Default geter going?

wanted to check up and see if you got your millenia started
Reply With Quote
  #5  
Old 01-14-2011, 12:15 PM
Junior Member
 
Join Date: Dec 2010
Posts: 3
Default

Nope. I got all the way to the fuel pump and found out it was working. You can't hear it when it's secure inside the tank so I though it wasn't working. I returned the new one I bought and tested if fuel was making it to the cylinders and it is. I checked for spark and not all the cylinders have spark. I'm assuming it's the ignition coil or just the whole distributor. The distributor that's on there is a Mitsubishi one, not Mazda.
Reply With Quote
Old 01-14-2011, 12:15 PM
 
 
 
Reply

Tags
1995, 95, bad, fuel, hear, location, mazda, millenia, pressure, pump, relay, relays, replace, sign, test


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Med Center Mazda
Pelham, AL 35235


All times are GMT -5. The time now is 07:32 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.