Go Back   Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda Millenia
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #11  
Old 09-26-2006, 12:34 PM
 
Join Date: Sep 2006
Posts: 12
Default RE: 2001 Millenia S *PROBLEMS*

The IAT problem is fixed. Still having a misfire on #1. The coil is new. Is there a way to test this off the car?
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #12  
Old 09-28-2006, 11:04 PM
 
Join Date: Sep 2006
Posts: 1
Default RE: 2001 Millenia S *PROBLEMS*

I have a 99 millenia S with 107,000 miles that has the same clanking sound that you are speaking of above 3000rpm. It seems to do it only under wide open throttle, and does not do it during a gentle accelleration. I just assumed that it was the supercharger going but, it may be an ignition problem. Anyway, I was just wondering if you ever narrowed down the clancking noise?
Reply With Quote
  #13  
Old 10-05-2006, 04:12 PM
 
Join Date: Sep 2006
Posts: 12
Default RE: 2001 Millenia S *PROBLEMS*

Does anyone know exactly what sensors affect the ignition system in the Miller cycle 2.3L engine?

If this car just idles, it will run for hours with no misfires or CEL lights coming on. But as soon as you try to drive it, the damn thing falls flat on it's face, won't rev past 3000, starts flashing a p0300 code (Random multiple misfire), and makes a god awful clattering and popping at whatever the max RPM hppens to be at that time. The temp gauge never exceeded midline.

The next thing I will try is to vent the exhaust prior to the after cat to see if it is clogged.

This car is going to kill me if I can't get it running strong.
Reply With Quote
  #14  
Old 10-04-2007, 01:25 PM
 
Join Date: Sep 2006
Posts: 12
Default RE: 2001 Millenia S *PROBLEMS*

Exactly a year later and this Millenia is still sitting here doing the same think it always has. Has anyone figured out anything else about theseenginesthis past year?
Reply With Quote
  #15  
Old 10-04-2007, 08:48 PM
 
Join Date: Sep 2007
Posts: 3
Default RE: 2001 Millenia S *PROBLEMS*

I don't have the answer as of yet. My 99 has very similar noise coming from the same place. I replaced the IAT and am looking at checking the number 1 coil (just got that to code). Have been dealing with a 1402 code (EGR) and will replace on Monday, put a usedEGRin and it seemed to help butdid not totally take care of the knocking, been told the EGR may be sticking.

Also, because of other posts, I have checked the vacuum lines to make sure they are connected properly. Foundtwo lines switched, but haven't checkedfor leaks completely. I was lead to the vacuum lines because my TCS light goes off after driving about 1/2 mile, it (TCS) comes on after the CEL light goeson and the knocking occurs. When the TCS comes on the engine cuts and only allows very low RPMS, must nurse back to shop. So i'm hopeing that replacing the EGR with a new onewill be the ticket, but not betting on it.

There is also the possibility that it is my computer, I have been lead to that by connecting the computer to the plugin under the hood. But, have been told the computer isn't usually the problem, it is actually the vacuum system.

I will post the results, but for you if your up to it...try checking the vacuum hoses. There was a color diagram posted earlier.

Also will be working on figuring out the 300 and 301 codes, as stated above i have the same codes. Will let you know my progress.
Reply With Quote
  #16  
Old 10-10-2007, 08:53 PM
 
Join Date: Sep 2007
Posts: 5
Default RE: 2001 Millenia S *PROBLEMS*

I had similar problems about 6 years ago when I installed the Bosch Platium 4 plugs. It took me $500+ and a new ignition module to learn that those plugs burn way too hot for the S engine.
Reply With Quote
  #17  
Old 09-12-2012, 04:08 PM
Junior Member
 
Join Date: Sep 2012
Posts: 1
Default 2001 mazda millinia

my girlfriends car won't start. hazards blink when she tries to start car, without her turning blinkers on . when i take it to mechanic it starts to work with out problems .
Reply With Quote
  #18  
Old 09-13-2012, 02:08 AM
Super Moderator
1997 Mazda 323
My Garage
 
Join Date: Feb 2012
Location: Tirol, Austria
Posts: 775
Default

Quote:
Originally Posted by Dwayne Musa View Post
my girlfriends car won't start. hazards blink when she tries to start car, without her turning blinkers on . when i take it to mechanic it starts to work with out problems .
First off I would like to welcome you to the site, second your needs would be MUCH better handled if you started a new thread and not dig up one that is over 5 years old ESPECIALLY one that has no relation to your problem, so if you could recreate your post in a new thread so this really old one can go back to its grave In the mean time I will see what I come up with about your problem.
__________________
1997 Mazda 323 1.3L 5-speed (130,000km)
2006 Mazda3 1.6L 5-speed (40,150km)
1989 Ford F250 7.3L IDI non-wastegated turbo 5-speed
239,000 miles and counting, ORIGINAL CLUTCH, still going strong. (In USA, dont have it here in AT)
Mostly
Always
Zipping
Dependably
Along

If I talk in this color it means I am speaking to you as a moderator, pay attention.
Reply With Quote
Old 09-13-2012, 02:08 AM
 
 
 
Reply

Tags
2001, cat, code, cylinder, difference, mazda, mellinia, millenia, misfire, multiple, noise, p0300, p1110, problem, random


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Med Center Mazda
Pelham, AL 35235


All times are GMT -5. The time now is 09:02 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.