Go Back   Mazda Forum - Mazda Enthusiast Forums > Mazda Vehicles > Mazda 323,Mazda 626 & Mazda 929
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-20-2010, 10:53 PM
Junior Member
 
Join Date: Apr 2010
Location: In florida
Posts: 5
Question 929 fast idle when cold

My wives 1991 929 stays on the fast idle 1600 rpm after cold start for 6-8 minutes I replaced the thermostat, the idle control unit on the valve cover with the water lines going to it, the TPS, I am not getting a check engine light anymore after replacing the TPS, but still the same problem does anyone have suggestions before I just keep spending more money I don't have. Please help I can't afford to take it in to get it diagnosed please help
Register today for free or log-in if already registered to remove this ad!
Reply With Quote
  #2  
Old 04-21-2010, 02:50 AM
Member
 
Join Date: Jul 2006
Location: Odessa, Ukraine
Posts: 89
Default

Useful info about 929 http://929.sentia.ru/english.htm
__________________
626 97 GF 1.8 Manual Transaxle Hatch Back
Reply With Quote
  #3  
Old 04-22-2010, 08:45 AM
Junior Member
 
Join Date: Apr 2010
Location: In florida
Posts: 5
Default I don't know how you found it

But thank you from the bottom of my heart I'll be sure to let you know how I make out but it looks like a ton of everything a person could need

1991929mazda
Reply With Quote
  #4  
Old 05-06-2010, 01:14 AM
Junior Member
 
Join Date: Apr 2010
Location: In florida
Posts: 5
Default

Well I have spent many hours searching and trying things from the sentia site but no luck most of it deals with the newer models I tried everything I could find to no avail I have found one thing that might be a problem but I don't know how to adjust it when we bought a used air flow sensor off ebay the screw cap for the factory adjustment had been removed I put it on and it runs better than the old one that died on us is it possible for this adjuster to cause the fast idle problem and is there a way to fix it other than getting anotherone????
Reply With Quote
  #5  
Old 05-22-2010, 04:08 AM
Junior Member
 
Join Date: May 2010
Location: East Palo Alto, CA
Posts: 4
Default

Did you have your TPS properly adjusted? Where did you get your Idle control unit? Are you referring idle control unit as the BAC valve? That should be on the intake manifold, not the valve cover.... and I dont recall there being a factory adjustment on the airflow sensor. Are you sure you have the right parts in mind here. There should be an adjustment on the BAC valve (ISC/IAC). How fast is idle when in Drive?
Reply With Quote
  #6  
Old 05-23-2010, 09:25 AM
Junior Member
 
Join Date: Apr 2010
Location: In florida
Posts: 5
Default

Yes I am sure about the tps adjustment and the adjustment on the air flow sensor you are correct there is not supposed to be an adjustment it is sealed but when I purchased the car the owner had drilled it out trying to fix the simple tune up problem this adjust the air fuel mixture and I did finally get the information on how to adjust it and that part works good now OK now I am not familiar with BAC but the ISC/IAC is on the valve cover on this model it is connected to the intake manifold via large vacuum lines one to the plenum between the AFS and the the other just behind the throttle body and I got this unit from the salvage yard from a wreaked car with 80,000 my car has 176,000 I figure the chance of this unit having the exact same problem was slim I would liked to have gotten the AFS but it was smashed now since my last post I cleaned the egr that slowed the idle by 1000 to 1600 cold 1100 in drive and I replaced the thermostat which I found it did not even have one but I am still stuck with the long cold idle time three too five minutes I found that If I leave the car out in the sun versus in the garage this is not as bad am I close to normal for this model or or am I just thinking wrong I have never had a fuel injected car take this long to adjust down from fast idle after the warm up time and idle down it works perfectly 650 in drive smooth it just seems that high cold high idle must be hard on the tranny Thanks so much for your time and help fill me in on this BAC please

Last edited by 1991929mazda; 05-23-2010 at 09:39 AM.
Reply With Quote
  #7  
Old 06-04-2010, 03:10 AM
Junior Member
 
Join Date: May 2010
Posts: 3
Default

play with your throttle position sensor by loosening nuts and adjust accordingly. hust remember where yo started backing them off for safety if does not work. spray throttle body cleaner inside throttle body. and run BG product 44k through gas tank. it last up to 3000 miles and will treat up to 20 gallons.
Reply With Quote
  #8  
Old 06-07-2010, 04:26 AM
Junior Member
 
Join Date: Apr 2010
Location: In florida
Posts: 5
Default

Well I thank every one for the help I sold the car today or I guess yesterday now and I got it as close as I could the guy that bought it seemrd happy my wife bought a new fusion ???????? don't ask she has to drive it anyway thank you all and have a good day.
Reply With Quote
Old 06-07-2010, 04:26 AM
 
 
 
Reply

Tags
323, 626, 929, adujust, bac, cold, fast, fuel, high, idle, injection, isc, mazda, mpv, start


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Med Center Mazda
Pelham, AL 35235


All times are GMT -5. The time now is 07:28 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.