Mazda 3 CEL came back after O2 Sensor replacement? - Mazda Forum - Mazda Enthusiast Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-15-2016, 10:05 PM
Junior Member
Thread Starter
 
Join Date: Dec 2016
Location: Clarkston, MI
Posts: 3
Exclamation Mazda 3 CEL came back after O2 Sensor replacement?

I just replaced my Bank 1 Sensor 1 O2 Sensor in my 2006 Mazda 3 because it had some bad codes on it. I cleared the codes on my Mazda, and now I'm getting codes p0134 p0131 p0030 p0031 Any help as to what the problem might be?
Reply With Quote
  #2  
Old 12-16-2016, 11:38 AM
Junior Member
Thread Starter
 
Join Date: Dec 2016
Location: Clarkston, MI
Posts: 3
Default

Bump*
Reply With Quote
  #3  
Old 12-16-2016, 04:39 PM
Junior Member
Thread Starter
 
Join Date: Dec 2016
Location: Clarkston, MI
Posts: 3
Default

Turns out my O2 Sensor wasn't plugged in all the way. The clips that hold in the O2 Sensor connector have been broken.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2016 Mazda6: Shifting back, forth, back and forth after stopping Header Mazda6 2 06-20-2016 09:46 PM
engine light came on ,diagnostic done code p103?? maestro Mazda MPV 3 07-27-2013 11:09 PM
Engine light came on????? ELSALV39 General Tech 15 07-15-2008 05:02 PM
2000 Mazda 626 - Check Engine light came on Cataphract Mazda 323,Mazda 626 & Mazda 929 3 12-08-2007 03:50 PM
what small trucks came with fiberglass beds from the factory?? mtrain Mazda Pickup Trucks 0 12-02-2007 06:38 PM


Tags
cel, mazda, mazda 3, o2 sensor, replacement

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:48 AM.